Heute ist mir auf der Arbeit dieses ahnunglose Notebook in die Hände gefallen – fünf Minuten später bootet es schon die Live-DVD.

Was läuft… Was nicht läuft…

Hardware-Specs

Was läuft (wenn auch mit Nachhilfe):

Und am Ende des Boot-Vorgangs wartete des erste Problem: Der X-Server konnte nicht gestartet werden, da die verwendete ATI-Karte nicht mit den mitgelieferten ATI-Treibern läuft und der Laptop-Monitor scheinbar nicht richtig per DPMS mit der Karte sprechen will.

Aber mit einer kleinen Änderung lässt sich diese kleine Hürde schnell beseitigen: Mit ALT+F2 auf eine Textkonsole wechseln und dort die Konfigurationsdatei des X-Servers mittels sudo nano /etc/X11/xorg.conf bearbeiten. Nun scrollt man bis zu Eintrag Section "Monitor" und trägt unterhalb von Identifier "Standardbildschirm" folgendes ein: Horizsync 28-49 und Vertrefresh 43-72. Die Zeile mit Option "DPMS" kommentiert man dann noch aus. Das Ganze sollte dann so aussehen:

Section "Monitor"

Identifier "Standardbildschirm"

#Option "DPMS"

Horizsync 28-49

Vertrefresh 43-72

EndSection

Dannach startet man noch mit sudo /etc/init.d/gdm restart den Anmeldebildschirm neu (manchmal hat dies bei mir nicht auf Anhieb geklappt, aber eine wiederholte Eingabe von sudo /etc/init.d/gdm restart führte dann zum Erfolg). Und voila, es präsentiert sich die normale Ubuntu-Installations-Oberfläche. Sollte es mit der eigentlichen Installation Probleme oder Verständnisschwierigkeiten geben, hilft diese Seite verlässlich weiter).

Nach der Installation kann man dann über die System->Administration ->Verwaltung eingeschränkter Treiber die Closed-Source AMD/ATI-Treiber aktivieren. Wer sicher gehen will, ändert nochmals die /etc/X11/xorg.conf und macht dort die oben beschriebenen Änderungen rückgängig, damit Ububtu die native Auflösung des Notebooks (1280×800) automatisch erkennt. Probleme machen leider die Stromspar-Modi der ATI-Karte: Zwar kann man per aticonfig –set-powerstate=1 eben diese aktivieren, nur zieren dann fünf vertikale Streifen von lila Farbe den Bildschirm; volle Power für den Grafikchip und sie verschwinden wieder. Doch dieses Problem wird ATI bestimmt irgendwann mit einem neuen Treiber beheben.

WLAN (Dell Wireless 1390) funktionierte auch nicht out-of-the-box. 🙂 Aber mit dieser ausführlichen Anleitung ist es kein Problem gewesen, das Latitude zum Funken zu überreden. Surfen ohne VPN-Client im GoeMobile-Netz hackt aber noch etwas, da zwar alles Dank der Erweiterungen für den NetworkManager klappt, aber leider die routen nicht gesetzt werden. Das war mir dann zuviel Frickelkram für einen Nachmittag, aber WPA und normalem drahtlosen Surfen steht nichts im Wege.

Wichtig ist auch, dass sich der Prozessor runtertaktet, die Stromspar-Modi also funktionieren – was man auch vom Suspend-to-RAM sagen kann. Zwar dauert es ein paar Sekunden, bis sich der Rechenknecht wieder genehmt, ein Bild zu zeigen, aber es funktioniert.

Was nicht läuft (auch mit Nachhilfe nicht):

Arbeiten an sich ist damit schon möglich, Bluetooth wird automatisch erkannt, die Treiber werden geladen, aber leider wollen die Frontends noch nicht so richtig.Aber der Cardbus funktioniert und ebenso der Firewire-Anschluss auf der linken Seite des Laptops scheint zu laufen, jedenfalls werden die Treiber dafür von Ubuntu geladen (ich habe zur Zeit leider kein Firefire-Gerät zur Hand, um die korrekte Funktion zu testen; das werde ich aber im Laufe der nächsten Tage nachholen).

Ein weiteres Problemkind ist die Soundkarte, eine ATI SB600 AZALIA. Es scheint eine Unterart von Intels HDA-Soundchip zu sein, der noch ein paar Probleme bereitet. Die Ubuntu-Entwickler haben diese zwar schon gelöst, doch per Update wird dieses Probleme erst behoben, wenn der neue 2.6.21er Kernel in Feisty Einzug hält. Es gibt zwar einen Fix, aber diesen Maßnahmen war bei meinem D531 kein Erfolg beschienen.

Was (noch) nicht funktioniert: Der Smartcard Reader und das Modem. Habe aber auch noch nicht alle Funktionen des Notebooks ausprobiert.

Alles in allem bleibt ein Notebook, mit dem man zwar schon arbeiten kann, aber solange Bluetooth und Sound nicht funktionieren, ist das nicht wirklich erfüllend. Aber mal sehen, was die nächsten Wochen bringen.

Hardware-Specs:

Prozessor: AMD Turion 64 X2 Mobile TL-56 1,8Ghz (Stromspar-Modus via powernow-k8)

Speicher: 1024 MB (2x512MB)

Display: 15,3“ (1280×800)

Chipsatz: ATI SB600

Ethernet: Broadcom NetXtreme BMC5755M (1000Mbit) (Kernelmodul: tg3)

Wireless: Dell Wireless 1390 (Broadcom, via ndiswrapper)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.