Wir betreiben hier an der Universität bekanntermaßen ein größes Linuxsystem. Von administrativer Seite ist das sehr schön, es gibt 3 Server von denen einer das Mastersystem darstellt und dessen Inhalt dann einfach via cron/rsync auf die beiden anderen gespiegelt wird.
Auf dem Mastersystem kann man wenn man lustig ist via VMware/Xen oder aktuell KVM dann auch direkt testen was man grad bei den Linuxclients so eingestellt hat, theoretisch jedenfalls. Da neben mir eine Dell Precision rumsteht nutze ich normalerweise einfach die, da kann man wenigstens auf der Tastatur oder dem Gehäuse rumschlagen, wenn etwas nicht so funktioniert.

Unser eingesetztes Linux ist allerdings schon etwas betagter und verhält sich nicht mehr so gewohnt wie z.B. mein Laptop 🙂
Letzte Woche war ich dann der Meinung man müßte mal wieder ein paar Updates einspielen unter anderem Flash, da gab’s neulich ja mal das ein oder andere Problem … Was mir nicht direkt aufgefallen war, war die Fehlermeldung das zwar das Paket runtergeladen wurde, aber die Installation fehlschlug. Daraufhin hat sich relativ schnell jemand beschwert das Youtube nicht mehr geht.
Also kurz von Hand installiert, wenn der Paketmanager das nicht automagisch erledigt. Dabei ist dann irgendwie Udev ein bisschen kaputt gegangen, das hat mir eine Gruppe auf dem System angelegt mit einem komplett falschen Namen, weswegen die Soundausgabe dann nicht mehr funktioniert hat. Den Fehler zu finden hat mich dann schon ein paar Minuten länger gekostet.
Lösung war dann wieder super einfach, die Gruppe umbenennen, dann gehören die Sounddevices auch wieder der Gruppe „Studenten“ mit der zugehörigen GID und nicht „Studenten“ mit der GID 112 .. Das ist nämlich eigentlich die Gruppe „audio“.

Gestern hat sich dann noch jemand beschwert das USB-Wechselmedien nicht mehr funktionieren, das hat mich auch wieder ein paar Minuten gekostet. Fazit: PolicyKit ist totaler Mist, deswegen hab ich das auf meinem Laptop vermutlich auch nicht drauf. Zumindest funktioniert es jetzt wieder so wie es soll.
Zuerst war ich so schlau und hab einfach mal alles was an PolicyKit geht mit „result=yes“ zurückgehen zu lassen, da war ich kurz gedanklich wohl woanders. Jetzt gibt er das nur noch für die Wechselmedien zurück und verhält sich sonst wie Ubuntu das voreinstellt 🙂

Jetzt muß ich nur noch herausbekommen warum udev und PolicyKit diesen Murks veranstalltet haben, das war irgendwie nicht so auf den ersten Blick ersichtlich. Vielleicht lass ich das auch einfach in Ruhe und beschäftige mich nochmal mit dem zukünftigen System, da gibt es auch noch ein paar Stolpersteine mit dem ndb als root-Device.

Securityupdates und Bugfixes

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.